Acces3 Tutorials and How-Tos


Tutorials

Using Answer Grids in your Documents

For instructions on how to use answer grids in your documents, along with samples of the different answer grid styles Acces offers, please download our "Answer Grids in Acces" tutorial.

PDF FileAnswer Grids in Acces (PDF)
Extracting and Editing a Problem

While creating a test document, you may want to change the wording, multiple-choice answers, or some other element of a problem you've selected from a catalog. To do this, you'll have to extract the problem and then edit it. Extracting a problem does two things. It:

  • Removes the problem's source information (database code, category code, and problem number) from the grid
  • Puts the text of the problem in the Commands column.
The process is NOT reversible, at least not automatically. If you do want to restore an extracted problem to its original state, you will have to re-enter the problem's source information into the grid AND delete the text in the Commands column.

To extract and edit a problem:

  1. Click on the row of the problem you want to edit.
  2. Press F5. You'll see a dialog box asking you if you want to extract the "Current" problem or "All Defined" problems. Select "Current" and press OK.
  3. You'll see a blue diamond in the Commands column of the grid. Click on that cell, and press Ctrl+E to bring up the Commands pop-up editor.
  4. The pop-up editor contains the text for the problem you've just extracted. Make your changes, and press OK.

Note: Changes you make to a problem never effect the compiled database; only the extracted text is modified. Also, since the text is in "raw form" and likely to contain many typesetting commands, we strongly recommend that you familiarize yourself with TeX, Acces' typesetting system, before you do any editing.

Separating a Document into Logical Parts

For simplicity, all major* layout options (such as the number of columns and the style of problem numbering) are global, that is, they affect all pages within a document. If you want to change your document so that different parts are laid out in different ways, you will need to separate your document into logical parts.

Basically, separating your document involves creating two or more Acces documents, each with their own layout options. The documents' starting pages and problem numbers are set so that when printed and put together, they appear to form one complete test. The following example describes how to create a 10-problem document where all problems except #8 are laid out in two columns.

Example: Mixing column layouts in a test
  1. Create an Acces document with items #1―7 in two columns, as usual. Print it out and see how many pages you've got.
  2. Create a new Acces document. Set it up the same as the first document, then make a few quick changes:
    1. Change the number of columns to 1
    2. Go to Layout > Page Setup and type the starting page number in the Start field. Press OK
    3. Go to Layout > Numbering and type in the starting problem number in the Start field (8, in this example). Press OK
    4. Fill in just one row on the grid (your 8th item), and print it out.
  3. Create another document. Set it up the same as the first document, except change the starting page number and problem number, as you did in Step 2
  4. Fill in the two rows of the grid (your 9th and 10th items) and print it out
  5. Put together the documents you created in steps 1―3. You should have a complete test with no obvious breaks except the column changes

* —"Major" layout options include Document Type, number of columns, numbering style, and all other options found in the Layout menu. Other layout options can be applied to your document on a per-problem basis using typesetting commands. Click on an empty cell in the Commands column and press Ctrl+L to see a list of commonly-used typesetting commands.

Turning Multiple-Choice Problems into Free-Response Problems

Acces can turn most multiple-choice problems into free-response by hiding, or suppressing, the answer choices. We say "most" because some problems do not make sense without their answer choices. Typically, these are worded like, "Which of the following is..." We have tried to identify all of those problems and mark them, so that their choices don't get hidden accidentally. For all other problems, the process of hiding choices is simple:

  1. In the Layout menu, select the Multiple Choice menu item
  2. Set the Layout option to "hidden" and press OK
This method turns ALL multiple choice problems in a document into free-response problems. If you want to convert only some problems of a document into free-response, you can do one of the following:

Method 1: Splitting your Acces document into separate parts

This method involves splitting an Acces document into two or more separate documents (or files). You can think of these as "logical parts". Each part can have its own layout options. Further, you can set the starting page and problem numbers, so that the parts, when printed and joined together, appear to be just one document.

For example, if you are creating a 20-problem test and you want to hide choices on the last 5 problems:

  1. Create an Acces document and add 15 problems. Preview the document and see how many pages it is (the test only, not the answer key)
  2. Create a second Acces document and add the last 5 problems. Change its layout options so that multiple-choice answers are hidden (see method above)
  3. In the Layout menu, select the Page Setup menu item. Type the starting page number in the Start field and press OK
  4. In the Layout menu, select the Numbering menu item. Type the starting problem number in the Start field (number 16 in this example) and press OK
  5. Print both documents, then join the pages to make a complete test

Method 2: Using typesetting commands

As you have probably noticed, options in the Layout menu affect an entire document. If you want to make problem-by-problem changes, then you need to make use of "typesetting commands". These are inserted into the "Commands" column on the grid. You can type them or, in many cases, choose them from a pop-up list.

Once again, as an example, assume you are creating a 20-problem test and you want to hide choices on the last 5 problems. Do this:

  1. Create an Acces document and add all 20 problems as usual
  2. Go to row 16 and click in the Commands column
  3. Type this command: \nochoices
  4. Repeat Step 3 on the remaining rows (17–20)
  5. Preview/print as usual

Shortcuts for entering commands:
If the Commands column is empty, you can use the pop-up list, which is probably faster than typing. Click on the cell in the Commands column and either go to Utilities > List Choices, OR press Ctrl+L. Highlight \nochoices in the list and press Enter. You'll see the command appear on the grid.

You can copy typesetting commands, including \nochoices, with Acces' "ditto feature". This means moving down one row (while staying in the Commands column) and pressing single or double quote. This special key copies whatever text is in the cell above.


How-Tos

How do I edit a reading passage?

Sometimes, you may want to edit a reading passage to highlight different vocabulary words, reword phrases, or correct errors in the text. This can be done by using a text editor like Notepad to open and edit the auxiliary file containing the text for the passage you want to change.

All auxiliary files for reading passages are in Acces' "Input" folder (by default C:\ACC\INPUT). The filenames for the auxiliary files are printed at the beginning of each passage in the database module's catalog. These files can be edited using a text editor that can save plain ASCII text files, such as Notepad.

To edit an auxiliary file with Notepad:

  1. Start the Notepad program (one way to do this is to click on the Start button, clicking on Run..., typing notepad, and clicking OK).
  2. In the File menu, select the Open... menu item.
  3. Locate and open the Acces "Input" folder (usually C:\ACC\INPUT).
  4. Double-click the .AUX file you want to edit.
  5. Edit the file, save it, and close Notepad.

For example, in the TX8 catalog, the auxiliary file for the passage titled "How Did Hanson Crockett Gregory Invent the Doughnut" is named TX4-004.AUX. To edit the passage using Notepad, follow the steps as described above, making sure to look for the TX4-004.AUX file while carrying out step 4.

How do I add Spanish accents and characters to my problems?

TeX, Acces' underlying typesetting engine, allows users to add international accents/characters to their documents by using special control characters. Here's a small subset of these special control characters:

DescriptionControl
Characters
ExampleOutput
Inverted Question Mark ?` ?`Si? ¿Si?
Inverted Exclamation Mark !` !`Si! ¡Si!
Acute Accent \' Est\'a Está
Tilde \~ Se\~nora Señora
Diéresis \" verg\"uenza vergüenza

These control characters can be typed in anywhere Acces expects TeX code to appear (like the Commands edit box, the USER.DIR file, and a reading passage's .AUX file). For example, if you were writing your own problem using the Commands pop-up editor, and you wanted to typeset the phrase: ¿Cuál es la idea principal del sexto párrafo? you would type in the following TeX code:

?`Cu\'al es la idea principal del sexto p\'arrafo?

How do I add my own figures/pictures to a problem?

Acces stores all of its graphics files in its Graphics subfolder (C:\ACC\Graphics by default). You can copy your own graphics files to this folder for Acces to use as long as they meet the following requirements:

  • The resolution of the graphic is 300 dpi
  • The graphic is black-and-white (also called "monochrome", 1-bit, or 2-color)
  • The graphic is saved in PCX or TIF format
There is no size requirement, although it's recommended that the graphic's width be less than 2.5 inches (750 pixels) for a two-column standardized test, or 4.5 (1350 pixels) inches for a one-column test/worksheet. Acces will scale graphics to fit (horizontally), but this can result in some distortion, so it's best if you create them at the right size. For multiple choice answers, graphics should be no more than about 1.5 x 1.5 inches (450 x 450 pixels), otherwise it's impossible to stack four or five of them in a single column.

Once you have your graphic in the Graphics subfolder, insert them into your document with the \picture command. See the "Special Effects" section in Chapter 4 of the Typesetting Guide for more details.

How do I add my own directions to a document?

User-created directions, or "user directions", are stored in the USER.DIR file located in the Acces program folder. You can use any text editor that supports saving plain ASCII text files, like Notepad, to add your own directions to this file.

Open the USER.DIR using a text editor and type in your directions. Each direction should have occupy one single line and be no more than 250 characters in length. TeX commands are active in this file, so you can put math formulas in directions or use any TeX commands that you know (be careful when using special characters like $ # and %; TeX treats these characters as special commands).

User directions are numbered automatically. The first user direction (that is, the first line of USER.DIR) is actually direction number 1001. Additional user directions are 1002, 1003, etc. When you pop up a list of directions in Acces (by clicking on a "Directions" cell and pressing CTRL+L), your user directions will be at the end of the list.

How do I add my own answers to the answer key?

Adding multiple choice answers are, of course, automatic. Simply mark the correct answer with an asterisk:

In the number 26{,}985, the ``6'' is in which place?

\emcee{
  \mc ten thousands place
 *\mc thousands place
  \mc hundreds place
  }

For open-ended answers, use the \newanswer{} command:

Who was Sherlock Holmes' nemesis?
\newanswer{Professor Moriarty}
Mathematical answers should be in between dollar signs, like this:
Reduce the following fraction:  $ \f{2}{24} $
\newanswer{$ \f{1}{12} $}

Note that the \newanswer{} command can be placed anywhere in a problem; it does not need to appear at the bottom of a problem.

How do I make a table smaller so that it fits within a page or column?

Sometimes, when creating tests laid out in multiple columns or printed with large fonts, data tables will be too wide to fit within a page or column. To get them to fit so they don't overflow onto neighboring columns or are cut off at the end of a page, you can try to shrink the font used in the table. This technique works for most—but not all—tables.

To shrink the table's font, you first need to extract and edit the problem containing the table. In the pop-up editor, look for the code used to create the table. Here's an example of some table code:

\linedtable{
& pages&     1& 2& 3&  4&  5& 6&  7&  8\cr
& postcards& 3& 6& 9& 12& 15& ?& 21& 24\cr}

Enclose this code in a pair of curly braces, and in those curly braces, insert a \basefontsize= command size, specifying a point size after the = sign. Using the example table above, if you want to shrink the table's font to be 10 points, you would modify the code to look like the following:

{\basefontsize=10pt
\linedtable{
& pages&     1& 2& 3&  4&  5& 6&  7&  8\cr
& postcards& 3& 6& 9& 12& 15& ?& 21& 24\cr}
}

Miscellaneous Notes

Things to know when editing a problem/passage for the first time

If you've never edited a reading passage or problem before, you might be a little confused when you encounter special characters and typesetting commands. Here's a list of things to watch out for and leave alone as you're editing:

  • There may be notes or comments embedded in the file. These always begin with a percent (%). You should not make any changes to these; they are not printed and are included only for informational purposes.

    Example:
    %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
    %  Note:  This auxiliary file is read by various Acces databases        %
    %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
  • There will be some typesetting command followed by regular text. The commands always begin with a backslash (\), and the regular text is usually inside curly braces. Leave the command and curly braces alone; you can make any changes you like to the regular text.

    Example:
    \PassageTitle{``I Can Help the Next Person in Line''}
    
    \medskip
    \PassageSubTitle{\biggerfont An Autobiography of a Bank Teller}
    \nobreak
    \smallskip
  • We use two grave accents (``) and two single quotes ('') to typeset real opening and closing quotations. Please use this kind of mark instead of typewriter-style quotations (").
  • You will occasionally notice a tilde (~) between words. This is not an accent and does not get printed. It is a tie character; it is used to prevent bad breaks. You can change the text around the tilde, but please do not remove it (The tilde is most often used to join titles to names and numbers to units).

    Example:
    Mr.~Smith had 2~pairs of sunglasses. Each pair weighs 3~ounces.
  • You will notice some commands for special handling of vocabulary words and font effects. We try to generalize the these things, which means we do not hard-wire in the font effects, so that changes can be made on the fly (e.g., some people may not like vocabulary words underlined). Please use \vocab{...} for any words that are referred to in questions. Use \ital{...}for anything you want to emphasize with italics.

    Example:
    The hooks themselves had to be shaped from nylon thread. Eventually
    George found that he could mold the thread into short loops with
    \vocab{infrared} heat. Next he cut each loop in half with clippers
    to leave two hooks facing each other.
    
    By 1958 George had his fastener. He called it ``Velcro,'' from the
    French words \ital{velours} (velvet) for the soft, fuzzy part and
    \ital{crochet} (hook) for the hooks.
  • There are a few other special symbols and commands that you may run across: \dots, --- (three hyphens), and \ (backslash-space). The dots command produces real typesetter dots, which are slightly different than three periods in-a-row. The blackslash-space is sometimes used to after an abbreviation; it signals that the period is not the end of the sentence. And the three hyphens mean a longer dash, what typesetters usually refer to as an em-dash. You can pretty much ignore these things. Obviously, you don't have to use any of these special symbols or commands; just don't delete any unless you are also deleting the text around them.
  • Line breaks and extra spaces do NOT matter. If you add/remove any text, you can break lines wherever it is convenient. Do not worry about word-wrap as you do with a normal word-processing document. Line breaks and spacing will be handled by Acces' typesetting system, when the passage is actually formatted. The only thing to pay attention to is paragraphs; they should always be separated by an extra (blank) line.

The difference between math and text fractions, or \f and \tf

Most of the time you should use math fractions, and definitely when you are doing something in math mode, like this:

What is $ \f12 + \f14 $?

There is also a variant, a large size fraction, which can be done with \F or \df (which stands for "displaystyle" fraction). The variant is typically used in a situation like this:

Simplify:  $ \df{x^2-2x-3}{x-3} $

where the fraction must be larger and clearly displayed. The normal \f command is designed for paragraphs and sentences, where you don't want fractions to "stick out" or cause ugly line spacing.

The text fraction command, \tf, is partly a convenience and partly to accommodate people who like different styles of fractions in non-mathematical situations. It's most appropriate when there are dimensional numbers in a sentence, like

3\tf12 miles, \tf12 yard, \tf32 cups

The appearance of text fractions can be controlled with this command, normally placed in Layout menu > Global commands:

\tfracstyle=#

where # is 0 (small), 1 (large), 2 (diagonal). Try each to see the difference. The default is 0. Because one of the options is diagonal, \tf should never be used in an inherently mathematical context, like a formula or addition problem. (The diagonal layout can lead to ambiguities.)

Note: numbers and dimensions should usually be tied together, like \tf14~mile.